System requirements

From Star Wars: Rise to Power Wiki
Jump to: navigation, search

This article is a stub. You can help Star Wars: Rise to Power Wiki by expanding it.

We don't yet have information on system requirements for the final release.

Closed Pre-Alpha Test[edit | edit source]

The Closed Pre-Alpha Test is currently only available for Android devices.

The pre-alpha version requires:

  • One of these devices:
    • Samsung Galaxy S4
    • Samsung Galaxy Tab 3 10.1
    • Samsung Galaxy Note 3
    • Samsung Galaxy Note 10.1 (2014)
    • Nexus 4
    • Nexus 7 (2013)
    • Moto G 2013
    • Any newer model of the above devices
  • Or a Android device with:
    • One of the following CPUs:
      • Qualcomm Snapdragon 400 / S4 Pro
      • Samsung Exynos 5410
      • NVidia Tegra T114
      • Marvell Armada PXA1088
      • Intel Atom Z2560
    • Or one of the following GPUs:
      • Adreno 305
      • Mali T628
      • Tegra 4
      • Vivante GC1000
      • PowerVR SGX544